php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4122 function imap_base64 leaks memory
Submitted: 2000-04-12 19:52 UTC Modified: 2000-06-17 19:40 UTC
From: sli at mailsurf dot com Assigned:
Status: Closed Package: IMAP related
PHP Version: 4.0 Latest CVS (12/04/2000) OS: Linux 2.2.5
Private report: No CVE-ID: None
 [2000-04-12 19:52 UTC] sli at mailsurf dot com
$binary = imap_base64($string);

causes the following error_log entries:

zend_hash.c(185) :  Freeing 0x082346D4 (20 bytes), script=/usr/local/apache/htdocs/email.php
zend_API.c(220) :  Freeing 0x08234674 (48 bytes), script=/usr/local/apache/htdocs/email.php
zend_API.c(209) : Actual location (location was relayed)

PHP configuration:

./configure --with-mysql \
            --with-imap \
            --with-zlib \
            --enable-track-vars \
            --enable-trans-sid \
            --with-apxs=/usr/local/apache/bin/apxs

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-04-13 19:44 UTC] chagenbu at cvs dot php dot net
Can you post the smallest script that results in this? I
can't reproduce it in current cvs.
 [2000-06-17 19:40 UTC] sli at mailsurf dot com
Couldn't reproduce the memory leak.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC