php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41200 (ibm-db2 + oracle-instant-client) == configure error
Submitted: 2007-04-26 11:47 UTC Modified: 2007-05-04 01:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jruizmail at gmail dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.2.1 OS: Linux (Gentoo) 2.6.20-r6
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-04-26 11:47 UTC] jruizmail at gmail dot com
Description:
------------
Hi

I'm trying to compile php-5.2.1 with db2 and with pdo-oci support (using instantclient).

Using my configure options, php compiles well (and works well) if I ONLY include support for db2, and the same if I ONLY include support for oracle-instantclient... but if I put both together I get a configure error like:

checking for IBM DB2 support... no
configure: error: 
build test failed. Please check the config.log for details.
You need to source your DB2 environment before running PHP configure:
# . $IBM_DB2/db2profile


of course, I sourced the db2profile script in (in my case) /home/db2inst2/sqllib/db2profile before running configure


Reproduce code:
---------------
./configure --prefix=/u01/LAMP/php-5.2.1 --exec-prefix=/u01/LAMP/php-5.2.1 --host=i686-pc-linux-gnu --cache-file=./config.cache --enable-maintainer-zts --enable-cli --with-apxs2=/u01/LAMP/apache-2.2.4/bin/apxs --without-pear --disable-bcmath --with-bz2 --disable-calendar --disable-ctype --without-curl --without-curlwrappers --enable-exif --without-fdftk --disable-filter --enable-ftp --with-gettext --without-gmp --disable-hash --disable-ipv6 --disable-json --without-kerberos --enable-mbstring --without-mhash --with-ncurses --disable-pcntl --without-recode --disable-shmop --without-snmp --enable-soap --enable-sockets --disable-sysvmsg --disable-sysvsem --disable-sysvshm --disable-wddx --with-libxml-dir=/u01/LAMP/libxml2-2.6.28 --with-xmlrpc --enable-zip --with-zlib --disable-debug --without-gdbm --with-inifile --without-qdbm --with-freetype-dir=/usr --with-t1lib=/usr --enable-gd-jis-conv --with-jpeg-dir=/usr --with-png-dir=/usr --with-gd --without-ldap-sasl --disable-dbase --without-fbsql --without-msql --with-mssql=/u01/LAMP/freetds-0.64 --with-pgsql=/u01/LAMP/postgresql-8.2.4 --without-sybase --without-sybase-ct --enable-dba --without-cdb --without-db4 --without-flatfile --with-mysql=/u01/LAMP/mysql-5.0.37 --without-mysqli --with-unixODBC=/u01/LAMP/unixODBC-2.2.12 --without-adabas --without-birdstep --without-dbmaker --without-empress --without-esoob --without-iodbc --without-sapdb --without-solid --with-pdo-dblib=/u01/LAMP/freetds-0.64 --with-pdo-mysql=/u01/LAMP/mysql-5.0.37 --with-pdo-odbc=unixODBC,/u01/LAMP/unixODBC-2.2.12 --with-pdo-pgsql=/u01/LAMP/postgresql-8.2.4 --with-pdo-sqlite --with-readline --without-libedit --without-mm --with-sqlite --enable-sqlite-utf8 --with-oci8=instantclient,/u01/LAMP/oracle-instantclient/lib --with-pdo-oci=instantclient,/u01/LAMP/oracle-instantclient,10.2.0.3 --with-ibm-db2=/opt/IBM/db2/V8.1

Expected result:
----------------
...
checking for IBM DB2 support... yes
...


Actual result:
--------------
checking for IBM DB2 support... no
configure: error: 
build test failed. Please check the config.log for details.
You need to source your DB2 environment before running PHP configure:
# . $IBM_DB2/db2profile


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-26 12:00 UTC] jruizmail at gmail dot com
Just a note:

I also tried using --with-ibm-db2=/home/db2inst2/sqllib and also tried setting the var IBM_DB2 to both /opt/IBM/db2/V8.1 and /home/db2inst2/sqllib locations, but if I include oracle support, same results...
 [2007-04-26 12:24 UTC] tony2001@php.net
Remove all configure options not required to reproduce it.
And check the config.log as was recommended by configure.
 [2007-04-26 13:11 UTC] jruizmail at gmail dot com
Ok, using:

./configure --with-oci8=instantclient,/u01/LAMP/oracle-instantclient/lib --with-pdo-oci=instantclient,/u01/LAMP/oracle-instantclient,10.2.0.3 --with-ibm-db2=/opt/IBM/db2/V8.1

same results:

checking for IBM DB2 support... no
configure: error: 
build test failed. Please check the config.log for details.
You need to source your DB2 environment before running PHP configure:
# . $IBM_DB2/db2profile


and config.log says:

configure:65533: checking for IBM DB2 support
configure:65606: gcc -o conftest -I/usr/include -g -O2  -L/usr/lib  -Wl,-rpath,/u01/LAMP/libxml2-2.6.28/lib -L/u01/LAMP/libxml2-2.6.28/lib -Wl,-rpath,/u01/LAMP/oracle-instantclient/lib -L/u01/LAMP/oracle-instantclient/lib conftest.c 
      -L/opt/IBM/db2/V8.1/lib -ldb2
     -lresolv -lm -ldl -lnsl  -lxml2 -lz -lm -lxml2 -lz -lm -lclntsh 1>&5
configure: failed program was:
#line 65595 "configure"
#include "confdefs.h"

    
    char SQLExecute();
    int main() {
      SQLExecute();
      return 0;
    }
  


I can confirm I get the same config.log messages including all the other configure options.

thanks!
 [2007-04-26 13:45 UTC] tony2001@php.net
Try to compile that code manually linking with both libclntsh and libdb2 and see what's wrong there.

 [2007-05-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 15 15:01:29 2024 UTC