php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41133 _SERVER['LOCAL_ADDR'] available in CGI not in ISAPI
Submitted: 2007-04-18 14:31 UTC Modified: 2007-04-18 14:51 UTC
From: j dot deroij at e-density dot nl Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.1 OS: Windows 2003
Private report: No CVE-ID: None
 [2007-04-18 14:31 UTC] j dot deroij at e-density dot nl
Description:
------------
I want to check the ip from the server
On windows with php as cgi module i can use _SERVER['local_addr']
but when i run php as isapi module this server var is gone. 
This is very strange because local_addr is a IIS var, so is must be the same thing for cgi and isapi or am i wrong?

Reproduce code:
---------------
$_SERVER['LOCAL_ADDR']

Expected result:
----------------
Ip of the server

Actual result:
--------------
doesn't exists

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-18 14:51 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Mar 22 22:03:41 2023 UTC