php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #41076 max_execution_time and max_input_time settings ignored
Submitted: 2007-04-13 14:47 UTC Modified: 2007-04-13 14:59 UTC
From: mail at arnebrodowski dot de Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.1 OS: Linux
Private report: No CVE-ID: None
 [2007-04-13 14:47 UTC] mail at arnebrodowski dot de
Description:
------------
Settings of max_execution_time and max_input_time in php.ini are ignored in the cli binary.

works with (see expected result):
$ php -v
PHP 5.1.6 (cli) (built: Sep 13 2006 15:56:23) 

doesn't work with:
$ php -v
PHP 5.2.1 (cli) (built: Feb 12 2007 14:36:29) 

I checked that the correct php.ini is loaded/parsed with:
$ strace php 2>&1 | grep ini
open("/etc/httpd/php-cli.ini", O_RDONLY) = 3
lstat64("/etc/httpd/php-cli.ini", {st_mode=S_IFREG|0644, st_size=45407, ...}) = 0

Reproduce code:
---------------
$ cat /etc/httpd/php-cli.ini | grep '^max_'
max_execution_time = 300
max_input_time = 300

$ php -r "phpinfo();" | grep '^max_'

Expected result:
----------------
max_execution_time => 0 => 300
max_input_time => -1 => 300

Actual result:
--------------
max_execution_time => 0 => 0
max_input_time => -1 => -1

(as a result my scripts stop processing input after 60 seconds)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-13 14:59 UTC] tony2001@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 22:05:43 2022 UTC