php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40978 PHP 5.2.1 Installer failure
Submitted: 2007-04-02 15:44 UTC Modified: 2008-08-22 18:10 UTC
Votes:6
Avg. Score:4.7 ± 0.7
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: jim_mcnally at yahoo dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.1 OS: Windows VISTA
Private report: No CVE-ID: None
 [2007-04-02 15:44 UTC] jim_mcnally at yahoo dot com
Description:
------------
PHP 5.2.1 installer package terminated before installing.  message from Vista: "There was a problem with this Windows Installer package. A program  that was run as part of this setup did not finish as expected. Contact your package vendor."

IIS v. 7.0 was installed and it works.
PHP 5.2.1 installer was run selecting "IIS CGI'. No other options were selected.
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-04 16:07 UTC] jim_mcnally at yahoo dot com
Additionally, I tried the PHP manual installation process, and got the dread ERROR 404.3. 

I also tried another installer package: "PHP Installer 1.6 for PHP 5.2.1 Setup" with the same results. 

ERROR 404.3 is given in full below. Any help would be most appreciated. 

Jim
------------------------------------------------------
HTTP Error 404.3 - Not Found
Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed. 

Error Code: 0x80070032 

Notification: ExecuteRequestHandler 

Module: StaticFileModule 

Requested URL: http://jtmal2:80/hello.php 

Physical Path: C:\inetpub\wwwroot\hello.php 

Logon User: Anonymous 

Logon Method: Anonymous 

Handler: StaticFile 

Most likely causes: 

It is possible that a handler mapping is missing. By default, the static file handler processes all content. 
The feature you are trying to use may not be installed. 
The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.) 
What you can try: 

In system.webServer/handlers: 
Ensure that the expected handler for the current page is mapped. 
Pay careful attention to preconditions (e.g. runtimeVersion, pipelineMode, bitness) and compare them to the settings for your application pool. 
Pay careful attention to typographical errors in the expected handler line. 
Please verify that the feature you are trying to use is installed. 
Verify that the MIME map is enabled or add the MIME map for the Web site using the command-line tool appcmd.exe. 
Open a command prompt and change directory to %windir%\system32\inetsrv. 
To set a MIME type, use the following syntax: appcmd set config /section:staticContent /+[fileExtension='string',mimeType='string'] 
The variable fileExtension string is the file name extension and the variable mimeType string is the file type description. 
For example, to add a MIME map for a file which has the extension ".xyz", type the following at the command prompt, and then press Enter: 
appcmd set config /section:staticContent /+[fileExtension='.xyz',mimeType='text/plain'] 
Warning: Ensure that this MIME mapping is needed for your Web server before adding it to the list. Configuration files such as .CONFIG or dynamic scripting pages such as .ASP or .ASPX, should not be downloaded directly and should always be processed through a handler. Other files such as database files or those used to store configuration, like .XML or .MDF, are sometimes used to store configuration information. Determine if clients can download these file types before enabling them. 
Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here. 
-----------------------------------------
 [2007-04-05 00:45 UTC] jim_mcnally at yahoo dot com
I was looking at the experiences of others. One suggestion was to activate the error log with the following DOS command to be run from the same directory as the installer package.

msiexec /i php-5.2.1RC3-win32-installer.msi /l*v error.log

When I tried this, the response was that msiexec couldn't open the package. 

Were these packages tested?!?!? 

I'd like to become a PHP user, but, frankly, I can't even get to first base.

Jim
 [2007-04-11 18:30 UTC] jim_mcnally at yahoo dot com
Problem solved!
It turns out that Vista has a security checkbox. Even administrators can be limited. Designed to protect, it can also frustrate. Once the security check was removed, the msi installer worked. (I had the same problem trying to install Apache).
Regards,
Jim
 [2007-04-11 18:33 UTC] johannes@php.net
Not PHP's problem -> Bogus
 [2007-04-24 15:32 UTC] jmertic@php.net
Added a check to see if you are an administrator in CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 01:03:34 2021 UTC