php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40954 Apache conection lost during php
Submitted: 2007-03-29 21:51 UTC Modified: 2007-04-03 18:48 UTC
From: gbasco at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.4.6 OS: Linux 2.6.9-42.ELsmp
Private report: No CVE-ID: None
 [2007-03-29 21:51 UTC] gbasco at gmail dot com
Description:
------------
Apache Webserver 20.52 with PHP lib4 4.4.6 works fine serving large images and normal html pages. But when it executes medium large , even a file only with phpinfo(); in it, its starts displaying the page then resets and the browser clear the page giving a no conection error. 

In the error_log a broken pipe msg appears at the same time.

[Thu Mar 29 16:21:00 2007] [info] (32)Broken pipe: core_output_filter: writing data to the network




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-29 21:53 UTC] gbasco at gmail dot com
I miss spelled the Apache Server version, its  Apache/2.0.52
 [2007-04-01 23:09 UTC] gbasco at gmail dot com
PHP Version 5.2.1

System  Linux xx 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686  
Build Date  Mar 30 2007 04:29:37  
Configure Command  './configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql'  
Server API  Apache 2.0 Handler  
Virtual Directory Support  disabled  
Configuration File (php.ini) Path  /usr/local/lib/php.ini  
PHP API  20041225  
PHP Extension  20060613  
Zend Extension  220060519  
Debug Build  no  
Thread Safety  disabled  
Zend Memory Manager  enabled  
IPv6 Support  enabled  
Registered PHP Streams  php, file, data, http, ftp  
Registered Stream Socket Transports  tcp, udp, unix, udg  
Registered Stream Filters  string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*  

[root@jpweb1 conf]# ../bin/httpd -V
Server version: Apache/2.2.4 (Unix)
Server built:   Mar 30 2007 04:24:59
Server's Module Magic Number: 20051115:4
Server loaded:  APR 1.2.8, APR-Util 1.2.8
Compiled using: APR 1.2.8, APR-Util 1.2.8
Architecture:   32-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"
 [2007-04-03 18:48 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 07:03:37 2022 UTC