php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #409 PHP PG95 tests fail
Submitted: 1998-05-28 10:48 UTC Modified: 1998-05-28 13:51 UTC
From: Geoff_Corey at yahoo dot com Assigned:
Status: Closed Package: PostgreSQL related
PHP Version: 3.0 Release Candidate 5 OS: RedHat 5.0
Private report: No CVE-ID: None
 [1998-05-28 10:48 UTC] Geoff_Corey at yahoo dot com
Compiled with Postgres support and not as an apache module. Installed version of Postgres 6.2.1

None of the tests in pg95 work even though the  userid is able to create databases and can connect to template1 database via psql.   I have checked the port and it is both 5432 in the script as well as postmaster.

During the compile I used /usr/include/pgsql for the Postgres directory and had to modify the makefile because it tacked on  /include on the end of the directory and could not find the postgres includes.   This is a minor problem that was easy to fix.

However, not being able to connect to Postgres is a major problem.   I have checked the FAQ and Manual and did not find any steps that I did not follow.  What is wrong here?

All basic function tests passed (i.e. make test)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-28 13:51 UTC] zeev
The pg95 tests aren't supposed to work, they're PHP2 tests.
I removed them, as well as the mSQL tests, until someone
finds the time to write thorough PHP3 test suites

Please consult with the php3@lists.php.net mailing list
as to how to resolve your postgres problems - that driver
is known to work fine.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Dec 13 19:01:27 2018 UTC