php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4081 Netscape 4.6 doesn't display phpinfo graphics.
Submitted: 2000-04-08 18:20 UTC Modified: 2000-10-04 12:21 UTC
From: rerowe at rowbee dot inebraska dot com Assigned:
Status: Closed Package: *General Issues
PHP Version: 4.0 Release Candidate 1 OS: Linux
Private report: No CVE-ID: None
 [2000-04-08 18:20 UTC] rerowe at rowbee dot inebraska dot com
<hr><a href="http://www.php.net/"><img src="/phpinfo?=PHPE9568F34-D428-11d2-A769-00AA001ACF42" border="0" align="right"></a>
System: Linux rowbee.inebraska.com 2.0.36 #1 Tue Oct 13 22:17:11 EDT 1998 i686 unknown<br>Build Date: Apr  8 2000
<br>Configure command:  './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-pgsql' '--disable-debug'<br>
php.ini path:  /usr/local/lib<br>
ZEND_DEBUG=0<br>
SAPI=Apache<br>
ZTS is undefined<hr><a href="http://www.zend.com/"><img src="/phpinfo?=PHPE9568F35-D428-11d2-A769-00AA001ACF42" border="0" align="right"></a>

Is the source as shown by netscape. The error I get in the apache log file is:

no acceptable variant (once per image)

The only difference in the access file is that the GET with Netscape is HTTP/1.0 and the GET with IE5 is HTTP/1.1.  This results in the 406 error I get with Netscape.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-24 13:51 UTC] sniper@php.net
I can not reproduce this with latest CVS.
Have you tried any newer (release) versions of PHP4 ?

--Jani
 [2000-07-24 13:52 UTC] sniper@php.net
Oops..flipped to wrong status. 

--Jani
 [2000-07-24 13:56 UTC] david@php.net
you did it again! status is feedback now
 [2000-07-24 14:44 UTC] rerowe at rowbee dot inebraska dot com
PHP Version 4.0.1pl2 - Netscape Version 4.61 Cleared memory and drive cache. Redhat 5.2 Compiled as a DSO. Error log no--- acceptable variant: /www/rowbee/phpinfo.
Access log-- [24/Jul/2000:07:35:16 -0500] "GET /phpinfo HTTP/1.0" 200 37112
[24/Jul/2000:07:35:16 -0500] "GET /phpinfo?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.0" 406 435
[24/Jul/2000:07:35:16 -0500] "GET /phpinfo?=PHPE9568F34-D428-11d2-A769-00AA001ACF42 HTTP/1.0" 406 435

 [2000-07-24 14:47 UTC] rerowe at rowbee dot inebraska dot com
oops, forgot this part...
This program makes use of the Zend scripting language engine:
Zend Engine v1.0.1, Copyright (c) 1998-2000 Zend Technologies
with Zend Optimizer v0.99, Copyright (c) 1998-2000, by Zend Technologies
 [2000-08-15 09:52 UTC] waldschrott@php.net
unable to reproduce on win, does it still happen using latest verions
 [2000-08-15 14:58 UTC] waldschrott@php.net

 [2000-08-15 15:43 UTC] hholzgra@php.net
my guess:

this is related to CGI SAPI 

request_info.request_uri is set to $PATH_INFO
value from environment assuming the script
had been called by executing php cgi with
the path to the script attached as PATH_INFO

in this case it looks like the hashbang method
has been used with the script files executeable
flag set and the path to the php cgi in the 
first line of the file encoded as
'#!/path/to/php-executeable'
so that there is no $PATH_INFO but a valid
$REQUEST_URI in the CGI environment

does anyone have a simple idea how to spot 
the call method used so that
request_info.request_uri can be set 
accordingly ... ?

PS: by the way i think the bug report form
    should have an additional "server api"
    input
 [2000-10-04 12:21 UTC] andi@php.net
Fixed in latest CVS
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC