php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40640 Performance issues with 5.2.1
Submitted: 2007-02-26 14:51 UTC Modified: 2007-02-26 22:58 UTC
From: info at a-wing dot co dot uk Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 5.2.1 OS: CentOS 4.4
Private report: No CVE-ID: None
 [2007-02-26 14:51 UTC] info at a-wing dot co dot uk
Description:
------------
After compiling PHP 5.2.1 on our devel boxes we find a performance hit compared to 5.2.0 as can be seen in the following bench.php results:

PHP 5.2.0
---------
simple             0.269
simplecall         0.472
simpleucall        0.829
simpleudcall       0.952
mandel             1.043
mandel2            1.203
ackermann(7)       0.859
ary(50000)         0.049
ary2(50000)        0.041
ary3(2000)         0.478
fibo(30)           2.093
hash1(50000)       0.088
hash2(500)         0.095
heapsort(20000)    0.279
matrix(20)         0.245
nestedloop(12)     0.458
sieve(30)          0.220
strcat(200000)     0.038
------------------------
Total              9.713


PHP 5.2.1
---------
simple             0.537
simplecall         0.957
simpleucall        1.429
simpleudcall       1.467
mandel             1.988
mandel2            2.506
ackermann(7)       1.646
ary(50000)         0.087
ary2(50000)        0.073
ary3(2000)         0.983
fibo(30)           3.744
hash1(50000)       0.176
hash2(500)         0.194
heapsort(20000)    0.541
matrix(20)         0.446
nestedloop(12)     0.808
sieve(30)          0.422
strcat(200000)     0.422
------------------------
Total             18.427

I have tried with GCC 4.1.0 and 3.4.6 with similar results.  Both versions were built with the same configuration options and CFLAGS (tried -march=i686 -msse2 and just leaving it to defaults with similar difference in speed).

I especially turn your attention to the strcat score which is terribly slow in 5.2.1.

I have also benched 5.2.2dev using the 1:30am GMT build on the 26th with the following results:

simple             0.330
simplecall         0.506
simpleucall        0.805
simpleudcall       0.921
mandel             1.091
mandel2            1.459
ackermann(7)       1.028
ary(50000)         0.057
ary2(50000)        0.048
ary3(2000)         0.642
fibo(30)           2.479
hash1(50000)       0.107
hash2(500)         0.127
heapsort(20000)    0.358
matrix(20)         0.294
nestedloop(12)     0.605
sieve(30)          0.275
strcat(200000)     0.162
------------------------
Total             11.293

Better than 5.2.1, but still slower than 5.2.0.

Reproduce code:
---------------
http://cvs.php.net/viewvc.cgi/ZendEngine2/bench.php?view=markup

Expected result:
----------------
Minimal difference in speed, maybe even a speed increase in 5.2.1.

Actual result:
--------------
5.2.1 takes twice as long compared to 5.2.0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-26 22:58 UTC] info at a-wing dot co dot uk
Several people on the internals list have tried and can't reproduce the problem so it must be something I am doing wrong.

Closing as Bogus.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 14:01:23 2020 UTC