php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40493 4.4.5 segfaults apache on some websites
Submitted: 2007-02-15 09:10 UTC Modified: 2007-02-15 15:31 UTC
From: rick at revenew dot nl Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 4.4.5 OS: debian sarge (stable)
Private report: No CVE-ID: None
 [2007-02-15 09:10 UTC] rick at revenew dot nl
Description:
------------
I upgraded to 4.4.5 from 4.4.5 on two of our servers. One 32bit system and one 64bit system. We host multiple sites on both servers. On both servers php 4.4.5 segfaults apache (1.3) with about half of the sites (not all). 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-15 09:16 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2007-02-15 09:22 UTC] rick at revenew dot nl
I am not quite sure what code is causing this. But we had at least 25 websites that were having this problem on 2 different servers. So it seems like some major bug to me... I rolled back both servers to 4.4.4, because we need to keep our service up offcourse. Will be testing on a development later.

I compiled php by hand with the following options:

./configure --prefix=/usr/local/php-4.4.5 --sysconfdir=/etc/php4/apache --localstatedir=/var --mandir=/usr/share/man --infodir=/usr/share/info --with-config-file-path=/etc/php4/apache --enable-inline-optimization --with-bz2 --with-png-dir=/usr --with-gd --enable-gd-native-ttf --with-freetype-dir=/usr --with-jpeg-dir=/usr --with-openssl --with-png --with-regex=system --with-ftp --with-zlib --enable-bcmath --enable-magic-quotes --enable-sockets --with-mysql=/usr --with-xml --enable-calendar --enable-dbx --enable-dbase --with-apxs=/usr/bin/apxs --enable-exif --enable-ftp --with-dom --with-pspell --with-t1lib --with-gettext --enable-mbstring --with-ldap --with-imap=/usr/local/imap-2004g --with-mcrypt
 [2007-02-15 09:25 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2007-02-15 10:08 UTC] tony2001@php.net
Please also try using this CVS snapshot, I believe it should fix the problem:
http://snaps.php.net/php4-STABLE-latest.tar.gz
 [2007-02-15 10:09 UTC] tony2001@php.net
(The next snapshot should be available in a couple of hours).
 [2007-02-15 15:17 UTC] rick at revenew dot nl
I haven't made a backtrace yet, but I did just compile the 13:30GMT snapshot, that seems to have fixed the problem. Maybe time for the 4.4.6 release ;)
 [2007-02-15 15:31 UTC] tony2001@php.net
That's up to release manager to decide.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 16 05:01:26 2019 UTC