php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40464 Session.save_path wont use default-value
Submitted: 2007-02-13 15:39 UTC Modified: 2007-03-01 00:01 UTC
From: benni at gniza dot org Assigned: iliaa
Status: Closed Package: *Configuration Issues
PHP Version: 5.2.1 OS: SuSE 9.3
Private report: No CVE-ID:
 [2007-02-13 15:39 UTC] benni at gniza dot org
Description:
------------
I can approve the behavior of BUG-ID 40434

Sessions won't work without setting a session.save_path explicitly! If you just comment the session.save_path-line you get the error:

====
SAFE MODE Restriction in effect. The script whose uid is XZY is not allowed to access owned by uid 0 in [Scriptname:Line of session_start()]
====

This behavior is either a bug or the manual is wrong.

Quote from the manual:
==
session.save_path defines [...]. Defaults to /tmp. 
==

If I explicitly set the save_path (to /tmp or somewhere else) all is okay!

Greetings Benjamin


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-01 00:01 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC