php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40443 session_start problem
Submitted: 2007-02-12 09:55 UTC Modified: 2007-02-13 09:12 UTC
From: lawatia_mhm at yahoo dot com Assigned:
Status: Not a bug Package: Safe Mode/open_basedir
PHP Version: 5.2.1 OS: CentOS
Private report: No CVE-ID: None
 [2007-02-12 09:55 UTC] lawatia_mhm at yahoo dot com
Description:
------------
Dear ..
When I used php 5.2.0 .. the Sound Library Script was working great with Safe mode ...

But yesterday when I Upgraded to 5.2.1 the library isn't working with Safe mode ...

****************************
Warning: session_start() [function.session-start]: SAFE MODE Restriction in effect. The script whose uid is 32025 is not allowed to access owned by uid 0 in /home/xxx/public_html/snd/admin/index.php on line 10

Fatal error: session_start() [<a href='function.session-start'>function.session-start</a>]: Failed to initialize storage module: files (path: ) in /home/xxx/public_html/snd/admin/index.php on line 10
**************************

How to fix the problem dear ?

Notes :
I disabled Safe mode .. the library worked but when I enabled it this what happened ..


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-12 10:03 UTC] tony2001@php.net
>The script whose uid is 32025 is not allowed to access
>owned by uid 0 in
Set appropriate session.save_path.
 [2007-02-12 10:25 UTC] lawatia_mhm at yahoo dot com
Dear you said :
Set appropriate session.save_path.

Can you tell me to what do I have to write dear :
; As of PHP 4.0.1, you can define the path as:
; 
;     session.save_path = "N;/path"       
;
; where N is an integer.  Instead of storing all the session files in
; /path, what this will do is use subdirectories N-levels deep, and
; store the session data in those directories.  This is useful if you      
; or your OS have problems with lots of files in one directory, and is
; a more efficient layout for servers that handle lots of sessions.            
; 
; NOTE 1: PHP will not create this directory structure automatically.
;         You can use the script in the ext/session dir for that purpose.
; NOTE 2: See the section on garbage collection below if you choose to         
;         use subdirectories for session storage
; 
; The file storage module creates files using mode 600 by default.
; You can change that by using
;
;     session.save_path = "N;MODE;/path"
; 
; where MODE is the octal representation of the mode. Note that this
; does not overwrite the process's umask.
;session.save_path = "/tmp"
 [2007-02-12 19:06 UTC] lawatia_mhm at yahoo dot com
Anybody here dear ?
 [2007-02-13 07:43 UTC] lawatia_mhm at yahoo dot com
Hello dear ..
any body here ?? ..

3 sites on the server can't do anything because of this problem :( ..
 [2007-02-13 09:12 UTC] bjori@php.net
I am sorry, but this is not a support forum.
We simply don't have the time nor the man power to answer 
all questions that can come up.

Please have a look at http://php.net/support for more 
appropriate places to ask.
 [2010-05-06 05:10 UTC] dagoemanu at msn dot com
Put the line
php_value session.save_path /home/username/tmp
in the .htaccess file.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Feb 23 17:01:25 2019 UTC