php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40411 Searching seems to have changed to a "sounds like" search instead of keyword?
Submitted: 2007-02-09 03:20 UTC Modified: 2007-02-10 14:04 UTC
From: schneis at selectron dot com Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: n/a
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2007-02-09 03:20 UTC] schneis at selectron dot com
Description:
------------
I used to be able to search the PHP.net site for keywords in functions and have it provide a short list of possible matches.  Now, it seems to be automatically redirecting to what the search thinks I meant (which keeps guessing wrong).

A quick example, searching the function list for the phrase keys will give me the pan page for the "cos()" function, not show me a list including the function I was after which was "array_keys()".

With over 9000 bugs matching "PHP.net Website problem search" in the database, I can't tell whether this has already been reported.

Expected result:
----------------
Either the ability to turn off the fuzzy searching or show a summary of possible matches (the original behavior as of a month or two ago).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-02-10 14:04 UTC] bjori@php.net
It depends on the mirror you use.
Some mirrors have sqlite setup and will use metaphone() to 
determine the most likely function you meant and redirect 
you.

So, this is "a feature, not a bug" :)
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 01 22:01:27 2023 UTC