php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40284 _REQUEST NOT POPULATED
Submitted: 2007-01-30 10:20 UTC Modified: 2007-01-30 10:25 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mirko at stranicata dot com Assigned:
Status: Not a bug Package: Variables related
PHP Version: 5.2.0 OS: Linux
Private report: No CVE-ID: None
 [2007-01-30 10:20 UTC] mirko at stranicata dot com
Description:
------------
_REQUEST variable is not populated until it's called directly 

Reproduce code:
---------------
<?php
// test.php?param1=value1
error_reporting(E_ALL);
var_export($GLOBALS['_REQUEST']);
?>

Expected result:
----------------
array('param1' => 'value1');

Actual result:
--------------
Notice: Undefined index: _REQUEST in /home/saiman/www/test.php on line 4
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-30 10:25 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 18:01:32 2024 UTC