php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40217 Installation problem and file upload using html post not working
Submitted: 2007-01-24 08:58 UTC Modified: 2008-08-22 18:09 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: ratneshmaurya at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP
Private report: No CVE-ID: None
 [2007-01-24 08:58 UTC] ratneshmaurya at gmail dot com
Description:
------------
While installing (with the installer) in IIS4+CGI Mode (Windows XP,
IIS6.0), I get an error message at the end of the installation (There is a
problem with this Windows Installer Package please contact...)

Every thing in my php scripts works fine except file upload using http post method.

I also tried Bug #26185, solution and added through command


C:\WINDOWS\system32> iisext.vbs" /AddFile "C:\Program
Files\PHP\php-cgi.exe" 1 PHP 1 "PHP: Hypertext Processor"

But it didnt solved the problem.


Reproduce code:
---------------
<form action = "upload.php"...
<input type = "file" ..../>
<input type = sumbit....../>
</form>

Expected result:
----------------
the file which i selected must get uploaded to the upload_temp_dir as specified in the file php.ini

The same code works for me on a different machine where the php was successfully installed.

Actual result:
--------------
no file got uploaded. i tried files with different sizes as low as 1kb. and specified different upload directories for upload. Nothing worked on that machine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-24 13:17 UTC] ratneshmaurya at gmail dot com
I tried the link. http://downloads.php.net/edink/php-5.2.1RC3-win32-installer.msi

It gives error, I think similar to that Iwas getting earliear

Error 1722.
 [2007-01-29 13:17 UTC] jmertic@php.net
Could you run it in verbose logging mode and e-mail the log file to jmertic@php.net? To run
in verbose logging mode issue the below command from the command prompt
( from the same directory where the install exists ):

msiexec /i php-5.2.1RC3-win32-installer.msi /l*v error.log
 [2007-02-02 21:12 UTC] bill dot stout at greenborder dot com
I'm experiencing the same problem.  

I've attempted to install RC3 and it does not want to upgrade 5.2.0.  Uninstalling 5.2.0 from Control Panel - Add or Remove Programs returns an error:

PHP 5.2.0
"The installer has encountered an unexpected error installing this package.  This may indicate a problem with this package.  The error code is 2343."
 [2007-02-07 16:51 UTC] dmaher at isppainting dot com
I have tried these steps and I am getting the same issue.
 [2007-02-15 19:41 UTC] jmertic@php.net
Please try the latest build. If you are still having problems, email the error.log file produced from the following to jmertic@php.net.

From the command line in the directory where you downloaded the installer:

msiexec /i php-5.2.1-win32-installer.msi /l*v error.log
 [2007-02-26 12:33 UTC] jmertic@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 16:03:34 2021 UTC