php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40208 Cannot modify header information
Submitted: 2007-01-23 11:57 UTC Modified: 2007-01-23 12:06 UTC
From: jos_php at yahoo dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.4.4 OS: linux
Private report: No CVE-ID:
 [2007-01-23 11:57 UTC] jos_php at yahoo dot com
Description:
------------
when I use header("Location: mailform.php"); function giving error "Cannot modify header information - headers already"

Reproduce code:
---------------
<body><?php
if (($_REQUEST['FromId'])!="")
{
  $FromId = $_REQUEST['FromId'] ; 
  $ToId = $_REQUEST['ToId'] ; 
  $subject = $_REQUEST['subject'] ;
  $message = $_REQUEST['message'] ;
  mail( $ToId, "Subject: $subject",
  $message, "From: $FromId" );
  echo "Thank you for using our mail form";
}
else
{
header("Location: mailform.php"); 
exit; 
}?>
</body>

Expected result:
----------------
It suppose to redirect to mailform.php

Actual result:
--------------
Warning: Cannot modify header information - headers already sent by (output started at /webcorp1/www/corpusers/a/c/acceptachildtoday.org/sendmail.php:7) in /webcorp1/www/corpusers/a/c/acceptachildtoday.org/sendmail.php on line 20


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-23 12:06 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 09:02:23 2014 UTC