php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40190 ?
Submitted: 2007-01-22 05:45 UTC Modified: 2007-01-22 07:00 UTC
From: vbazuke at hotmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.0 OS: Win XP
Private report: No CVE-ID: None
 [2007-01-22 05:45 UTC] vbazuke at hotmail dot com
Description:
------------
When using a variable inside a output.

Reproduce code:
---------------
echo "<INPUT TYPE=text name=something1[]>";
//It's Okay

$i=1;

echo "<INPUT TYPE=text name=something$i[]";
//Return a parse error

Expected result:
----------------
A normal box named something1[].

Actual result:
--------------
Parse error: parse error, unexpected ']', expecting T_STRING or T_VARIABLE or T_NUM_STRING in C:\AppServ\www\coritibafc\bolao\apostas.php on line 32

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-22 07:00 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 19:04:05 2022 UTC