php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40148 Segfault when pspell extension is enabled
Submitted: 2007-01-16 18:31 UTC Modified: 2007-01-16 22:53 UTC
From: rick at gibbed dot us Assigned:
Status: Not a bug Package: Pspell related
PHP Version: 5.2.0 OS: FreeBSD 6.1
Private report: No CVE-ID: None
 [2007-01-16 18:31 UTC] rick at gibbed dot us
Description:
------------
PHP install from scratch causes crash on exit when pspell extension is loaded.

A similar bugreport can be found at http://bugs.php.net/bug.php?id=40007 which was disregarded because of a zend extension.

Reproduce code:
---------------
php -v

Actual result:
--------------
PHP 5.2.0 with Suhosin-Patch 0.9.6.2 (cli) (built: Jan 16 2007 12:00:18) 
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
Segmentation fault: 11 (core dumped)


gdb /usr/local/bin/php php.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.3
Reading symbols from /lib/libm.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.4
Reading symbols from /usr/local/lib/libxml2.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /lib/libz.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.3
Reading symbols from /usr/local/lib/libiconv.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /usr/local/lib/php/20060613/session.so...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/php/20060613/session.so
Reading symbols from /libexec/ld-elf.so.1...(no debugging symbols found)...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x28ff1ea8 in __do_global_dtors_aux () from /usr/local/lib/php/20060613/session.so
#2  0x28ff9078 in _fini () from /usr/local/lib/php/20060613/session.so
#3  0x28274018 in tls_dtv_generation () from /libexec/ld-elf.so.1
#4  0x282753d8 in ?? () from /libexec/ld-elf.so.1
#5  0xbfbfe818 in ?? ()
#6  0x2825c08e in elf_hash () from /libexec/ld-elf.so.1
#7  0x2825e970 in dlclose () from /libexec/ld-elf.so.1
#8  0x0815e40d in zend_hash_apply_deleter ()
#9  0x0815e49c in zend_hash_graceful_reverse_destroy ()
#10 0x08153f7f in zend_shutdown ()
#11 0x08116852 in php_module_shutdown ()
#12 0x081d7544 in main ()
(gdb) where full
#0  0x00000000 in ?? ()
No symbol table info available.
#1  0x28ff1ea8 in __do_global_dtors_aux () from /usr/local/lib/php/20060613/session.so
No symbol table info available.
#2  0x28ff9078 in _fini () from /usr/local/lib/php/20060613/session.so
No symbol table info available.
#3  0x28274018 in tls_dtv_generation () from /libexec/ld-elf.so.1
No symbol table info available.
#4  0x282753d8 in ?? () from /libexec/ld-elf.so.1
No symbol table info available.
#5  0xbfbfe818 in ?? ()
No symbol table info available.
#6  0x2825c08e in elf_hash () from /libexec/ld-elf.so.1
No symbol table info available.
#7  0x2825e970 in dlclose () from /libexec/ld-elf.so.1
No symbol table info available.
#8  0x0815e40d in zend_hash_apply_deleter ()
No symbol table info available.
#9  0x0815e49c in zend_hash_graceful_reverse_destroy ()
No symbol table info available.
#10 0x08153f7f in zend_shutdown ()
No symbol table info available.
#11 0x08116852 in php_module_shutdown ()
No symbol table info available.
#12 0x081d7544 in main ()
No symbol table info available.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-16 18:53 UTC] sesser@php.net
This actually seems to be FreeBSD Loader bug.

For no obvious reason sometimes some extensions (especially pspell.so) crash on unload. In some cases it can be fixed by just moving the crashing extension to the front or to the end of your extension.ini.

The real reason for this is however unknown. But it only seems to happen on FreeBSD.
 [2007-01-16 19:08 UTC] rick at gibbed dot us
Moving pspell.so to the end of the extension list does fix it, thanks.
 [2007-01-16 22:53 UTC] johannes@php.net
Not really a PHP problem (as in "we could fix it") - marking it bogus.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 11:01:25 2019 UTC