php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40132 Build error in ext/imap (U8T_CANONICAL def missing)
Submitted: 2007-01-15 10:15 UTC Modified: 2007-01-20 19:28 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: mathias dot lieber at web dot de Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 5.2.0 OS: Linux, 2.6.18, Ubuntu/Debian
Private report: No CVE-ID:
 [2007-01-15 10:15 UTC] mathias dot lieber at web dot de
Description:
------------
5.2.0 does not build because it's missing the definition of "U8T_CANONICAL" in the imap extension. I tried both with libc-client-dev package as well as with self-compiled imapd.2006XXX.TAR.GZ.

Reproduce code:
---------------
./configure --with-gettext --with-imap --with-imap-ssl --with-zlib --with-gd --with-mcrypt --with-openssl --with-xml --without-pear --with-apxs2=/usr/local/apache2/bin/apxs --enable-memory-limit --enable-track-vars --enable-wddx --enable-ftp --enable-gd-native-ttf --enable-sysvmsg --enable-sysvem --enable-sysvshm --enable-transid --disable-debug --disable-magic-quotes --with-mysql --enable-cli --enable-cgi --with-ldap --with-kerberos --with-mssql=/usr/local/freetds --enable-force-cgi-redirect

make



Actual result:
--------------
/bin/sh /usr/local/src/php-5.2.0/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/imap/ -I/usr/local/src/php-5.2.0/ext/imap/ -DPHP_ATOM_INC -I/usr/local/src/php-5.2.0/include -I/usr/local/src/php-5.2.0/main -I/usr/local/src/php-5.2.0 -I/usr/include/libxml2 -I/usr/local/src/php-5.2.0/ext/date/lib -I/usr/local/include -I/usr/local/src/php-5.2.0/ext/mbstring/oniguruma -I/usr/local/src/php-5.2.0/ext/mbstring/libmbfl -I/usr/local/src/php-5.2.0/ext/mbstring/libmbfl/mbfl -I/usr/local/freetds/include -I/usr/include/mysql -I/usr/local/src/php-5.2.0/TSRM -I/usr/local/src/php-5.2.0/Zend    -I/usr/include -g -O2  -prefer-non-pic -c /usr/local/src/php-5.2.0/ext/imap/php_imap.c -o ext/imap/php_imap.lo 
/usr/local/src/php-5.2.0/ext/imap/php_imap.c: In function 'zif_imap_utf8':
/usr/local/src/php-5.2.0/ext/imap/php_imap.c:2188: error: 'U8T_CANONICAL' undeclared (first use in this function)
/usr/local/src/php-5.2.0/ext/imap/php_imap.c:2188: error: (Each undeclared identifier is reported only once
/usr/local/src/php-5.2.0/ext/imap/php_imap.c:2188: error: for each function it appears in.)
make: *** [ext/imap/php_imap.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-17 10:37 UTC] tony2001@php.net
Make sure you've installed c-client properly and its headers define U8T_CANONICAL constant.
Look for utf8.h in imap-2006+ it contains U8T_CANONICAL definition.

 [2007-01-19 17:31 UTC] phpbugs at thequod dot de
I could still build PHP at Jan 14 2007 01:46:28.

Now I get the following error with current CVS:
/PHP_5_2/ext/imap/php_imap.c: In function 'zif_imap_utf8':
/PHP_5_2/ext/imap/php_imap.c:2212: error: 'U8T_CANONICAL' 
undeclared (first use in this function)

I have libc-client-dev 7:2002edebian1-13 installed on 
Ubuntu Dapper and U8T_CANONICAL is not defined 
in /usr/include/c-client/utf8.h. It's defined nowhere 
in /usr/include.
 [2007-01-19 17:47 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2007-01-19 21:34 UTC] phpbugs at thequod dot de
checking for U8T_CANONICAL... no
configure: error: utf8_mime2text() has new signature, but 
U8T_CANONICAL is missing. This should not happen. Check 
config.log for additional information.
I'll send you config.log.
 [2007-01-19 21:46 UTC] tony2001@php.net
/usr/include/c-client/nntp.h:64: error: syntax error before 'FILE'

What is the version of your imap package?
Where did you get it? Please put nntp.h online and paste the URL here.

 [2007-01-19 22:34 UTC] tony2001@php.net
Check next snapshot @ snaps.php.net (in a couple of hours), it should be fixed there.
 [2007-01-20 00:05 UTC] phpbugs at thequod dot de
Works for me now. Thanks.
 [2007-01-20 19:28 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Great, thanks.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 01:01:59 2014 UTC