php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #40094 Looking dor dlls in the wrong place
Submitted: 2007-01-10 19:02 UTC Modified: 2008-08-22 18:45 UTC
From: joebcohen at aol dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP Pro SP2
Private report: No CVE-ID: None
 [2007-01-10 19:02 UTC] joebcohen at aol dot com
Description:
------------
Just installed new version of PHP into C:\PHP using .msi
I am running Windows XP Pro SP2 - Apache 2.0 - install went clean.  Despite the errors reported below, the two modules are to be found in \PHP\ext and in \WINDOWS\System32.   Where is the PHP5 coming from ?     Joe at: joebcohen@aol.com

=========>
C:\>php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_gd2.dll'
- The specified module could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_mysql.dll
' - The specified module could not be found.
 in Unknown on line 0
PHP 5.2.0 (cli) (built: Nov  2 2006 11:57:36)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

C:\>

=============>

Reproduce code:
---------------
Just installed new version of PHP into C:\PHP using .msi
I am running Windows XP Pro SP2 - Apache 2.0 - install went clean.  Despite the errors reported below, the two modules are to be found in \PHP\ext and in \WINDOWS\System32.   Where is the PHP5 coming from ?     Joe at: joebcohen@aol.com

=========>
C:\>php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_gd2.dll'
- The specified module could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_mysql.dll
' - The specified module could not be found.
 in Unknown on line 0
PHP 5.2.0 (cli) (built: Nov  2 2006 11:57:36)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

C:\>

=============>

Expected result:
----------------
just the nice output expected from "php -v"

Actual result:
--------------
Just installed new version of PHP into C:\PHP using .msi
I am running Windows XP Pro SP2 - Apache 2.0 - install went clean.  Despite the errors reported below, the two modules are to be found in \PHP\ext and in \WINDOWS\System32.   Where is the PHP5 coming from ?     Joe at: joebcohen@aol.com

=========>
C:\>php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_gd2.dll'
- The specified module could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php5\php_mysql.dll
' - The specified module could not be found.
 in Unknown on line 0
PHP 5.2.0 (cli) (built: Nov  2 2006 11:57:36)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

C:\>

=============>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-11 09:37 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 07:03:34 2021 UTC