php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #39924 IMAP module lacks support for important/relevant parts of the imap spec
Submitted: 2006-12-21 15:04 UTC Modified: 2016-12-02 18:08 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: benjamin dot podszun at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: IMAP related
PHP Version: 5.2.0 OS: Irrelevant
Private report: No CVE-ID: None
 [2006-12-21 15:04 UTC] benjamin dot podszun at gmail dot com
Description:
------------
IMAP [1] supports a CAPABILITY command to check for various supported extensions. While the c-client library supports checking for capabilities, PHP doesn't offer any way to do that.

One of that extensions, NAMESPACE [2], is critical for applications that use php and imap in combination with a server that relies on different namespaces for the user inbox and for example the shared folders.
Without support for this command (which again is already available in the c-client library and "only" needs exposure/wrapping) there's no way to access shared folders on a server that supports multiple namespaces and therefor things like listing shared folders, subscribing to shared folders etc. cannot work reliably (without hardcoding/hacking the namespace in).

Proposal: Support for both protocol details should be added. I guess it's a no-brainer for anyone with a little experience with php modules and C.

[1] http://www.ietf.org/rfc/rfc2060.txt
[2] http://www.rfc-editor.org/rfc/rfc2342.txt

Reproduce code:
---------------
n/a

Expected result:
----------------
Improved support for the imap protocol, especially for the CAPABILITIES and NAMESPACE part.

Actual result:
--------------
No support at all yet.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-17 11:59 UTC] benjamin dot podszun at gmail dot com
I'd love to help out with this feature, but I lack the required skills (read: C and basic knowledge of building/creating/hacking php modules).
If any dev has some minutes to lend me a helping hand I'd try to start this on my own..
 [2011-04-08 21:06 UTC] jani@php.net
-Package: Feature/Change Request +Package: IMAP related
 [2016-12-02 18:08 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-12-02 18:08 UTC] cmb@php.net
This is a duplicate of feature request #38712.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Oct 17 00:01:27 2019 UTC