php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39801 Windows installer does not enforce cURL dependency of pecl_http
Submitted: 2006-12-11 21:26 UTC Modified: 2008-08-22 17:38 UTC
From: php at ahlenstorf dot ch Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2006-12-11 21:26 UTC] php at ahlenstorf dot ch
Description:
------------
When installing PHP using the Windows Installer of PHP 5.2.0 and you install pecl_http *but not* cURL, PHP will be unable to load the pecl_http extension because pecl_http is built against cURL. Thus, when installing pecl_http the installer should install cURL too.

Reproduce code:
---------------
Install PHP 5.2.0 with pecl_http and without cURL using the Windows Installer and launch your webserver (e.g. Apache 2.2).

Expected result:
----------------
pecl_http showing up in output of phpinfo();

Actual result:
--------------
Log message in Apache error.log:

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Programme\PHP\\ext\\php_http.dll' - Das angegebene Modul wurde nicht gefunden.\r\n in Unknown on line 0


(Translation of the german part of the error message: "The configured module could not be found").

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-11 22:52 UTC] tony2001@php.net
John, I'm not sure the installer should do this, but you might want to look into it.
 [2006-12-12 16:32 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC