php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39799 Windows installer does not set PHPIniDir properly
Submitted: 2006-12-11 15:53 UTC Modified: 2008-08-22 17:37 UTC
From: php at ahlenstorf dot ch Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2006-12-11 15:53 UTC] php at ahlenstorf dot ch
Description:
------------
The Windows Installer of PHP 5.2.0 fails to properly set the PHPIniDir directive in Apache 2.2.3. Result: PHP does not use the php.ini configured by the Windows Installer residing in C:\Programme\PHP (or whatever your install dir of PHP is). Instead it looks for a php.ini in C:\Windows.

The cause of the problem is the usage of single backslashes in the path:

PHPIniDir "C:\Programme\PHP\"

Using double backslashes like

PHPIniDir "C:\\Programme\\PHP\\"

or forward slashes like

PHPIniDir "C:/Programme/PHP/"

will fix the problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-11 15:58 UTC] tony2001@php.net
John, please check this out.
 [2006-12-12 16:31 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 15:03:33 2021 UTC