php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #39767 Binary Read of POST Data
Submitted: 2006-12-07 15:42 UTC Modified: 2009-05-10 17:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: deepak dot vasudevan at lavanyadeepak dot tk Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.4.4 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2006-12-07 15:42 UTC] deepak dot vasudevan at lavanyadeepak dot tk
Description:
------------
PHP Should provide access to BinaryData that is posted from the client similar to Request.BinaryRead in ASP. This would facilitate huge uploads without overloading the client.

Additionally, PHP should not preprocess this since if it attempts preprocesses and fills the superglobal array, we would again get entrapped in the size restrictions. If it does not then we can keep saving the buffers as it arrives from the web browser.

Actual result:
--------------
It would minimize the number of configuration changes to pHP.INI for huge file uploads by directly querying the binary data.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-10 17:00 UTC] jani@php.net
php://input
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 12:01:29 2024 UTC