php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39757 Distinguished names - openssl_csr_new
Submitted: 2006-12-06 16:19 UTC Modified: 2018-05-05 18:45 UTC
From: bassijunior at yahoo dot com dot br Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 5.2.0 OS: Windows XP Professinal
Private report: No CVE-ID: None
 [2006-12-06 16:19 UTC] bassijunior at yahoo dot com dot br
Description:
------------
Hi, 

I need to create a certificate request(CSR) using a openssl_csr_new function.

But I have a problem with the openssl.cnf file.

In the section distinguished_name has a several fields, like a countryName, emailAddress and others.

My commonName has the length bigger than 64, that is standard value of openssl.cnf. But I can`t change this valeu to the commonName_max = 128. I already tried all possible things. The openssl.cnf file is not accepting changes in this field.

Is it a bug?  

Thanks!


Reproduce code:
---------------
<?php.
.
.
.

$dn = array(
"commonName" => some name bigger than 64
);


openssl_csr_new($dn, $privkey, $config);

.
.
.
?>

Actual result:
--------------
The certificate request(CSR) was not created because the length of commonName.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-05 18:45 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Type: Feature/Change Request +Type: Bug -Package: Feature/Change Request +Package: *General Issues
 [2018-05-05 18:45 UTC] requinix@php.net
Old bug report is old.

I highly doubt this was an issue with PHP itself but with the OpenSSL configuration.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sat Nov 17 02:01:25 2018 UTC