php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39732 oci_bind_array_by_name doesn't work
Submitted: 2006-12-04 16:42 UTC Modified: 2006-12-08 20:56 UTC
From: fred dot cohen at iridium dot com Assigned: tony2001
Status: Closed Package: OCI8 related
PHP Version: 5.2.0 OS: Solaris 10
Private report: No CVE-ID:
 [2006-12-04 16:42 UTC] fred dot cohen at iridium dot com
Description:
------------
Attempting to execute the example code for oci_band_array_by_name  generates PHP Warning:  oci_execute(): OCI_NO_DATA in /.../test.php on line 49

No data is inserted into the tables and no values are updated in the passed array.

oci8 Version 	1.2.2, $Revision: 1.269.2.16.2.25 $
Oracle Version 	10.1

Compile flag: --with-oci8=/.../10.2.0/client_1

Our oracle server version in 9.2.0.7

Reproduce code:
---------------
http://us2.php.net/oci_bind_array_by_name example code.

Actual result:
--------------
PHP Warning:  oci_execute(): OCI_NO_DATA in /.../test.php on line 49
array(5) {
  [0]=>
  string(3) "one"
  [1]=>
  string(3) "two"
  [2]=>
  string(5) "three"
  [3]=>
  string(4) "four"
  [4]=>
  string(4) "five"
}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-04 17:02 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

Works just fine here, both on Solaris 8 and Linux.
 [2006-12-08 17:26 UTC] fred dot cohen at iridium dot com
Same problem is showing up using php5.2-200612081330 snapshot.
 [2006-12-08 17:40 UTC] tony2001@php.net
I'm unable to reproduce it.
Please provide more information on your system.
 [2006-12-08 17:57 UTC] fred dot cohen at iridium dot com
System 	SunOS web-internal 5.10 Generic_118833-03 sun4u
Build Date 	Dec 8 2006 16:04:00
Configure Command 	'./configure' '--sharedstatedir=/var/zone/php/com' '--localstatedir=/var/zone/php/var' '--with-apxs2=/usr/local/apache2/bin/apxs' '--disable-cgi' '--disable-path-info-check' '--with-config-file-path=/usr/local/etc/php/' '--disable-ipv6' '--with-openssl=/usr/local/ssl' '--with-zlib' '--enable-bcmath' '--with-bz2' '--enable-calendar' '--enable-ftp' '--with-gd=/usr/local' '--with-freetype-dir=/usr/local' '--enable-mbstring' '--with-libmbfl' '--with-sybase=/usr/local/freetds' '--with-mysql=/usr/local/mysql/' '--with-oci8=/opt/oracle/product/10.2.0/client_1' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--with-pear=/var/zone/php/lib'
Server API 	Apache 2.0 Handler

What else can I add about our configuration?

Problem appears using both command-line and web.
 [2006-12-08 18:28 UTC] tony2001@php.net
Please provide an account on this machine.
 [2006-12-08 20:56 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 15:02:26 2014 UTC