php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39716 win-installer: Missing quotes in php.ini when setting extension_dir
Submitted: 2006-12-02 21:07 UTC Modified: 2008-08-22 17:37 UTC
From: fabian dot deutsch at gmx dot de Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Microsoft Windows 2003 Server
Private report: No CVE-ID: None
 [2006-12-02 21:07 UTC] fabian dot deutsch at gmx dot de
Description:
------------
When using the win-installer for 5.2.0, on Microsofts WIndows 2003 Server 64bit, in conjunction with apache 2.2.3, the installer fails parsing the extension_dir line (after setting it), because there are no qoutes around the pathname.
This happens, because the filepath does contain whitespaces.

Reproduce code:
---------------
Use the win-installer and install it into a path containing whitespaces.

Expected result:
----------------
Clean install, even with whitespaces in pathnames.

Actual result:
--------------
The installer spawns a warning and you aren't able to start php, without modifications of the php.ini. (Add the missing quotes)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-04 15:47 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 05:03:12 2021 UTC