php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39712 Installation failure "Program Required"
Submitted: 2006-12-02 03:40 UTC Modified: 2008-08-22 17:37 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: kemputer at optushome dot com dot au Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.0 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2006-12-02 03:40 UTC] kemputer at optushome dot com dot au
Description:
------------
Installaing PHP V 5.2 from the msi installation file terminated prematurely with a message "A program required for this install to complete could not be run. Contact your support personnel etc". This is followed a a final installation wizard page informing that the process terminated prematurely and didn't complete

I uninstalled php and repeated the installation many times, each time getting the same message irrespective of what ever flavour of IIS I selected form the early installation option

regards

Colin


Expected result:
----------------
Expectation is a clean installation of php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-02 06:35 UTC] bjori@php.net
Which mirror did you use to download PHP?
 [2006-12-02 07:23 UTC] kemputer at optushome dot com dot au
I used AusGamers on http://au2.php.net/distributions/php-5.2.0-win32-installer.msi

I had tried Planet Mirror au.php.net but the download hung on 40Kb.
 [2006-12-04 15:48 UTC] jmertic@php.net
Do you get the same error if you choose not configure a web server?
 [2006-12-08 23:38 UTC] kemputer at optushome dot com dot au
If I install the php msi kit without configuring a server, there is no error. Installation appears to be clean.

(Sorry, for the delay in replying, I was away from my office)
 [2006-12-18 16:40 UTC] jmertic@php.net
Could you run it in verbose logging mode and attach the log file? To run in verbose logging mode issue the below command from the command prompt ( from the same directory where the install exists ):

msiexec /i php-5.2.0-win32-installer.msi /l*v error.log
 [2006-12-20 11:35 UTC] jack dot magielse at 3bm dot nl
I had the same problem when installing on a windows 2003 server with IIS 6. I ran the installation with the log option. The error.log is 498kb. Where can I drop it.
 [2006-12-21 12:43 UTC] jmertic@php.net
E-mail the error log to jmertic@php.net.
 [2006-12-21 13:21 UTC] jmertic@php.net
Can you try to run the following command from the command prompt and let me know the results:


 [2006-12-21 13:44 UTC] jmertic@php.net
I forgot this was already fixed by Bug #39410 in CVS. 

Thanks for all your feedback!
 [2006-12-21 23:16 UTC] kemputer at optushome dot com dot au
I note that this submission is now flagged as closed, however the problem is very real to me.

As requested, I have produced an error.log.

How do I upload it? 
If I cut and paste to the comment area, I get a warning about not spamming the site.

Seasons Greetings to all
 [2007-01-03 14:41 UTC] jmertic@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2007-01-03 14:41 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 14:03:33 2021 UTC