php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39543 ImageTTFBBox & any2eucjp
Submitted: 2006-11-17 09:10 UTC Modified: 2007-08-06 16:51 UTC
From: mdelorme at tennaxia dot com Assigned: pajoye (profile)
Status: Not a bug Package: GD related
PHP Version: 5.2.0 OS: Suse 10.1
Private report: No CVE-ID: None
 [2006-11-17 09:10 UTC] mdelorme at tennaxia dot com
Description:
------------
To be more accurate I've got
PHP Version 5.1.2
gd
--------------
GD Support 	enabled
GD Version 	bundled (2.0.28 compatible)
FreeType Support 	enabled
FreeType Linkage 	with freetype
FreeType Version 	2.1.10
GIF Read Support 	enabled
GIF Create Support 	enabled
JPG Support 	enabled
PNG Support 	enabled
WBMP Support 	enabled
XPM Support 	enabled
XBM Support 	enabled
JIS-mapped Japanese Font Support 	enabled

Reproduce code:
---------------
<?php
$bounds = ImageTTFBBox(9,0,               '/home/max/workspace/wwwdev/libraries/jpgraph/ttf/arial.ttf',
'Volume pr?lev? eau de ville'
);
?>

Expected result:
----------------
no warning

Actual result:
--------------
Warning: imagettfbbox() [function.imagettfbbox]: any2eucjp(): invalid code in input string in /home/max/workspace/wwwdev/web/test.php on line 5


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-17 10:52 UTC] tony2001@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2007-08-06 16:51 UTC] pajoye@php.net
Duplicate of #42218.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 08 13:05:46 2022 UTC