php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39539 new GtkEventBox crash
Submitted: 2006-11-16 21:57 UTC Modified: 2007-05-10 18:18 UTC
From: n dot escuder at intra-links dot com Assigned:
Status: Closed Package: PHP-GTK related
PHP Version: 5.2.0 OS: Linux
Private report: No CVE-ID: None
 [2006-11-16 21:57 UTC] n dot escuder at intra-links dot com
Description:
------------
php gtk 2 from CVS crash when creating an object of type GtkEventBox()

Reproduce code:
---------------
new GtkEventBox();

Expected result:
----------------
None

Actual result:
--------------
Crash the program

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-12-07 05:02 UTC] andrei@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I cannot reproduce this with PHP-GTK CVS and PHP 5.2.0RC4-dev.
 [2006-12-15 01:00 UTC] php-gtk-dev at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2007-01-26 19:38 UTC] n dot escuder at intra-links dot com
Sorry for the long time of the answer.

So i try with php 5.2.0 and i checkout the lastest version of php_gtk and it always crash... i don't known why...

gdb backtrace :
#178 0xbeeff400 in ?? ()
#179 0x001000b7 in ?? ()
#180 0xb76a3600 in zim_GtkWidget_show_now () from /usr/lib/php/extensions/php_gtk2.so
Previous frame inner to this frame (corrupt stack?)

X11R7 Version 7.1
GTK+ Version 2.10.6

For information i actually use and old php_gtk2 checkout version that work fine.

If you want i can give you an ssh access.

See You
 [2007-05-10 18:17 UTC] n dot escuder at intra-links dot com
If i build on the first machine and try on it or another = crash.

But if i build on another and try on another = no crash.

So it's a dependancy problem.

Sorry.
 [2007-05-10 18:18 UTC] n dot escuder at intra-links dot com
If i build on the first machine and try on it or another = crash.

But if i build on another and try on another = no crash.

So it's a dependancy problem.

Sorry.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 21:05:52 2022 UTC