php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39509 mySQL without InnoDB
Submitted: 2006-11-14 12:46 UTC Modified: 2006-11-15 16:30 UTC
From: tinu at humbapa dot ch Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5CVS-2006-11-14 (CVS) OS: Linux
Private report: No CVE-ID: None
 [2006-11-14 12:46 UTC] tinu at humbapa dot ch
Description:
------------
my mysql-server is running without innodb (skip-innodb in my.cnf).

with php 5.1.6 this worked fine.

when I try the same with the latest php from cvs (or 5.2.0) I get an error message about innodb...

do I always have to enable innodb with php >5.1.6 ?

Reproduce code:
---------------
<?
mysql_connect('localhost', 'root', 'anypassword');
?>

Expected result:
----------------
connect to mysql or show at least some error messages...

Actual result:
--------------
the page wont't load. 
my apache error-log contains:
061114 13:27:57 [Warning] Can't create test file /var/lib/mysql/hostname.lower-test
061114 13:27:57  InnoDB: Operating system error number 13 in a file operation.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-14 12:58 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

PHP provides just an interface, it doesn't require anything.
 [2006-11-15 16:30 UTC] tinu at humbapa dot ch
just in case someone else has the same problem...  :-)

I configured php with --enable-embedded-mysqli
removing this option solved my problem.

why mysql_connect() conflicts with this option I
have no idea.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 05:01:33 2024 UTC