php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39413 "bugfix" in Zend/zend_execute.c breaks PEAR install
Submitted: 2006-11-07 11:26 UTC Modified: 2006-11-07 18:29 UTC
From: need dot coffee at gmail dot com Assigned: iliaa (profile)
Status: Closed Package: Class/Object related
PHP Version: 4CVS-2006-11-06 (snap) OS: *
Private report: No CVE-ID: None
 [2006-11-07 11:26 UTC] need dot coffee at gmail dot com
Description:
------------
First, I know this isn't the place for a PEAR bug; it 
doesn't
appear to be a PEAR bug...

Trying to install php4-STABLE-200611061330 fails at PEAR
installation time with "Fatal error: Call to a member 
function on a non-object in [,,,]/pear/PEAR/Installer/Role/
Common.php on line 90."

The pear code hasn't changed since I was able to last 
install; however PHP code has.  If I revert the change 
recently made in Zend/zend_compile.c, it installs fine:

--- Zend/zend_compile.c~	Sun Oct 15 14:32:37 2006
+++ Zend/zend_compile.c	Mon Nov  6 21:21:41 2006
@@ -1164,7 +1164,7 @@
 
 		if (zend_hash_find(&ce->parent->function_table, ce-
>parent->name, ce->parent->name_length+1, (void **) 
&function)==SUCCESS) {
 			/* inherit parent's constructor */
-			zend_hash_update(&ce->function_table, ce-
>parent->name, ce->parent->name_length+1, function, sizeof
(zend_function), NULL);
+			zend_hash_update(&ce->function_table, ce->name, 
ce->name_length+1, function, sizeof(zend_function), NULL);
 			function_add_ref(function);
 		}
 	}


Reproduce code:
---------------
Download a recent snap and try to run 'make install'.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-07 18:29 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 18:01:30 2024 UTC