php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39375 PHP Warning: imap_fetchstructure(): No body information available in a.php
Submitted: 2006-11-04 11:03 UTC Modified: 2006-11-16 01:00 UTC
Votes:11
Avg. Score:4.4 ± 0.8
Reproduced:10 of 10 (100.0%)
Same Version:3 (30.0%)
Same OS:6 (60.0%)
From: queences dot sam at tallysolutions dot com Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 5.2.0 OS: linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-11-04 11:03 UTC] queences dot sam at tallysolutions dot com
Description:
------------
While tring to process mails from the mailbox using imap function at times we encounter this error. But the mail number etc everything that it picks up is correct. Below given line is the exact error that we get:

PHP Warning:  imap_fetchstructure(): No body information available in /var/www/html/tallyweb/modules/forums/intranet/CRecvMailProcessMgr.php on line 1044


We have noticed that the error goes of once we restart the services - sendmail, httpd & mysql.

Please let us know if this is already a noted bug in PHP imap library. When is it going to be resolved.

Queences


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-08 13:59 UTC] tony2001@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2006-11-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-02-01 17:48 UTC] matt at educause dot edu
I'm experiencing this issue too ... using IMAP ... using IIS/FastCGI ... PHP 5.2.5
 [2012-02-26 15:50 UTC] ike at spamfence dot net
The problem is depending upon the used IMAP server. For instance it doesn't work 
with zoho.com. (But the same code works with Yahoo)

I guess that's a flaw in the used IMAP server and not really a PHP problem. But 
PHP could do a workaround if possible.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 21 16:01:24 2020 UTC