php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39358 INSTALL_HEADERS contains incorrect reference to php_filter.h
Submitted: 2006-11-03 10:51 UTC Modified: 2006-11-03 20:09 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: kennyz at nycap dot rr dot com Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 5.2.0 OS: Linux
Private report: No CVE-ID:
 [2006-11-03 10:51 UTC] kennyz at nycap dot rr dot com
Description:
------------
The ./configure script for PHP 5.2.0 contains a small error that affects the directory layout after a "make install".

On line 32682 of configure, the line:

    for header_file in $ext_srcdir/php_filter.h; do

causes $header_file to contain the full path to php_filter.h, instead of a relative path like all of the other $header_file settings throughout ./configure.

Therefore, if $ext_srcdir is /usr/local/src/php-5.2.0, the installation location for the filter extension ends up being:

$(INSTALL_ROOT)/usr/include/php/usr/local/src/php-5.2.0/ext/filter, which is obviously not correct.


The Makefile that was generated from ./configure clearly shows the problem:

INSTALL_HEADERS = ext/libxml/php_libxml.h ext/pcre/php_pcre.h ext/pcre/pcrelib/
ext/date/php_date.h ext/date/lib/timelib.h ext/date/lib/timelib_structs.h ext/date/lib/timelib_config.h ext/dom/xml_common.h /usr/local/src/php-5.2.0/ext/filter/php_filter.h ext/gd/ ext/gd/libgd/ ext/hash/php_hash.h ext/hash/php_hash_md.h .................

The full path to php_filter.h is caused by the mistake on line 32682 in ./configure.

The correct line in ./configure should be:

    for header_file in ext/filter/php_filter.h; do


This fixes the problem in the resulting Makefile, and therefore fixes the issue with the bad layout after "make install".





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-03 20:09 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 09:02:29 2014 UTC