php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39336 openssl ciphers not properly initialized in 4.4.4
Submitted: 2006-11-01 18:08 UTC Modified: 2006-11-08 14:12 UTC
From: seanius at debian dot org Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.4.4 OS: Debian GNU/Linux
Private report: No CVE-ID: None
 [2006-11-01 18:08 UTC] seanius at debian dot org
Description:
------------
in php4 4.4.4x and later using openssl 0.9.8a and later, ssl protocols are not available to functions like readfile() et al.  this is because the list of ciphers are not properly initialized in ext/openssl/openssl.c

the patch provided in php bug #38798 solves the problem correctly.

note that this problem is also the cause of php bug #35160,
which imho was wrongly closed.  

the rationale that "it must be a problem with the precompiled  openssl libs, because it compiles fine with a fresh openssl and the latest 5.x php"
was particularly amusing, because in the latest php 5.x
code the patch from #38798 has already been applied, whereas it has not been applied yet in 4.4.4 :)

Reproduce code:
---------------
readfile("https://www.google.com");

Expected result:
----------------
html content

Actual result:
--------------
copelandia[~]18:56:21$ php4 foo.php

Warning: readfile(): php_stream_sock_ssl_activate_with_method: failed to create an SSL context in /home/seanius/foo.php on line 2

Warning: readfile(https://www.google.com): failed to open stream: Unable to activate SSL mode in /home/seanius/foo.php on line 2



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-02 06:52 UTC] judas dot iscariote at gmail dot com
>was particularly amusing, because in the latest php 5.x
>code the patch from #38798 has already been applied, whereas >it has not
>been applied yet in 4.4.4 :)

This have a reason, PHP4 active development has ceased permanently . people is focused on 5.2 and 6.

So, PHP4 issues gets liltle or no attention. is time for you to tell the debian people to move to PHP5 ASAP. anyway.. fix seems to be small.. wait to see if somebody is willing to look into this.

However. this bug is bogus, since is a duplicated of 
#38798
 [2006-11-08 14:12 UTC] tony2001@php.net
Duplicate of bug #38798.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 17:05:53 2022 UTC