php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39321 $_FILES empty with enctype=multipart/form-data
Submitted: 2006-10-31 15:33 UTC Modified: 2006-11-08 14:58 UTC
From: josh at pixael dot com Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.4.4 OS: linux
Private report: No CVE-ID: None
 [2006-10-31 15:33 UTC] josh at pixael dot com
Description:
------------
i'm trying to upload a file via ssl in a form with method post and enctype=multipart/form-data

if i upload a gif or jpg is all right

if i upload a txt or a pdf or other with INTERNET EXPLORER $_FILES and $_POST is empty

with firefox i've no problem

php version 4.3.9

this is the url of the test https://www.service-store.com/tst.php

Reproduce code:
---------------
<html>

<head>

<title>File Upload Test</title>

<meta http-equiv="Content-Type" content="text/html;">

</head>



<body bgcolor="#FFFFFF">

<pre>

<?php
error_reporting(E_ALL);

echo'Print $_POST<br />';
print_r($_POST);
echo'<br />Print $_FILES<br />';

print_r($_FILES);

?>

</pre>

<form enctype="multipart/form-data" action="tst.php" method="post">

<input type="hidden" name="MAX_FILE_SIZE" value="20000000">
<input type="hidden" name="VAR1" value="1">

Send this file: <input type="file" name="userfile[]">

<input type="hidden" name="VAR2" value="2">

<input type="submit" value="Test">

</form>

</body>

</html>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-11-01 06:51 UTC] judas dot iscariote at gmail dot com
this has been reported before, and seems to be a internet explorer bug. nothing to do with PHP I think.
 [2006-11-08 14:58 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Apr 13 17:01:30 2024 UTC