php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39289 all right in CGI/FastCGI mode, but not right in ISAPI mode.
Submitted: 2006-10-28 12:10 UTC Modified: 2006-10-28 16:22 UTC
From: bin at tbswe dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.1.6 OS: Windows 2003
Private report: No CVE-ID: None
 [2006-10-28 12:10 UTC] bin at tbswe dot com
Description:
------------
I have a Win2003 server with IIS.
Today i upgrade to PHP5.1.6 from PHP4.4.4,
but a problem came out.
It can successful run in CGI mode,
but when i changed it to ISAPI mode, it cannot run.
Then I tried to call PHPINFO(),
It successfully processed, but MYSQL module could not be found in the list.( NO ERROR REPORTING )
In the same PHP.ini, CGI mode could load MYSQL module. 

And there was "extension=php_mysql.dll" in PHP.INI already.

Reproduce code:
---------------
<?php
phpinfo();
?>

Expected result:
----------------
MySQL Support enabled 

Actual result:
--------------
MYSQL could not be found in the list.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-28 16:22 UTC] edink@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 14 11:01:28 2024 UTC