php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39204 MsSq_Fetch_* return Empty (Var)Char as single space
Submitted: 2006-10-20 06:55 UTC Modified: 2006-10-20 08:59 UTC
From: bertrand dot lepoittevin at groupe-mma dot fr Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.4.4 OS: Windows 2000
Private report: No CVE-ID: None
 [2006-10-20 06:55 UTC] bertrand dot lepoittevin at groupe-mma dot fr
Description:
------------
Hi,

When reading Sql Char or Varchar Values which are empty (""), mssql_fetch_* functions returns a single space, instead of returning empty string.

According to me this is a bug, right trimming values is just a workaround, and make thing more complicated when we need to compare values (form) and sql values.

I know there is old issues of this problem (since PHP v4.3.4), but :
- Is it really a ntwdblib.dll bug ? And which V? of this file corrects the MS bug ?
- It it possible to avoid this pb in MSSQL APIs ?

Ref : 
Sql server 8.0, ntwdblib.dll V2000.80.194.0

Regards.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-20 08:56 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Uprade your ntwdblib.dll and please search in existing bug-reports before reporting.
 [2006-10-20 08:59 UTC] bertrand dot lepoittevin at groupe-mma dot fr
Thanx for your quick reply,
i will try to upgrade ntwdblib.dll.

Best Regards.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 09:05:54 2022 UTC