php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #392 < and > not changed to &lt; and &gt; in source highlightning mode
Submitted: 1998-05-21 08:54 UTC Modified: 1998-05-21 20:54 UTC
From: jah at cultnet dot fi Assigned:
Status: Closed Package: Other
PHP Version: 3.0 Latest CVS OS: Any
Private report: No CVE-ID: None
 [1998-05-21 08:54 UTC] jah at cultnet dot fi
< and > are not changed to &lt; and &gt; in source
highlightning mode if they are on a comment line starting
with //.

The story how I found out this must be told... Besides, it's
also an example of how to reproduce the bug.

I wrote an example how to display tree structures in tables
and for completeness sake did also intended from right to
left for hebrew or arabic speaking php-users. After finding
an annoying misbehaviour in Netscape, I put these lines in
the source:

	// Netscape seems not to like this...
	// $tmpstr .= "<td colspan=$span width=$pixels>";
	$tmpstr .= "<td colspan=$span>";

Then, after submitting the example to Berber's example pages
and going back to look at it, I found it to be in two columns
and you guess where the split to next cell happened... Now,
let's see how this bug report looks out. :)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-21 20:54 UTC] zeev
Fixed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 02:05:53 2022 UTC