php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3918 Adding --enable-rule=EAPI with configure won't add -DEAPI at compile time.
Submitted: 2000-03-24 10:02 UTC Modified: 2000-03-30 07:50 UTC
From: Nikko at guilde dot org Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 4.0 Beta 4 Patch Level 1 OS: RedHat 6.0
Private report: No CVE-ID: None
 [2000-03-24 10:02 UTC] Nikko at guilde dot org
Here is the configure line :
[nikko@ica php-4.0b4pl1]$ ./configure  --with-apxs=/usr/local/apache/bin/apxs --with-mysql=/usr --with-xml --with-ldap --with-dbase --enable-versioning --enable-track-vars --enable-rule=EAPI

The when it compiles there is no -DEAPI on compile lines ...
It looks like it compiles correctely but when it load with apache that say that :

[Thu Mar 16 15:14:05 2000] [warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
[Thu Mar 16 15:14:05 2000] [notice] Apache/1.3.12 (Unix) mod_ssl/2.6.2 OpenSSL/0.9.5 PHP/4.0b4pl1 PHP/3.0.15 AuthMySQL/2.20 configured -- resuming normal operations

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-03-30 07:50 UTC] sas at cvs dot php dot net
Fixed in CVS. Thanks for your report.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 18:34:40 2020 UTC