php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39145 OUT Parameter is not changing
Submitted: 2006-10-13 10:19 UTC Modified: 2006-12-24 14:01 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sbreiler at gmx dot de Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.2.0RC5 OS: Windows XP SP2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sbreiler at gmx dot de
New email:
PHP Version: OS:

 

 [2006-10-13 10:19 UTC] sbreiler at gmx dot de
Description:
------------
Please have a look at the code below. I also tried to use a Variant, which doesn't worked out for me. Also "$mycom->myFunction( &$FunctionName );" doesn't work.

Tried with PHP version "5.2.0.0 RC6-dev" and "5.1.6.6"

Reproduce code:
---------------
$mycom = new COM('my.own');
settype($FunctionName,"String");
//$FunctionName = 'a'; // **doesn't work either
$mycom->myFunction( $FunctionName ); /* VT_PTR [26] [out] --> VT_BSTR [8]  */
var_dump($FunctionName); // '' or 'a'**

Expected result:
----------------
'something'

Actual result:
--------------
'' or 'a' (when using "$FunctionName = 'a';")

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-13 10:25 UTC] sbreiler at gmx dot de
In Delphi it looks like this (and is working):

[code]
procedure TForm1.Button1Click(Sender: TObject);
var
  mycom: Variant;
  FunctionName: String;
begin
  mycom := CreateOleObject('my.own'); // or CreateComObject
  mycom.myFunction(FunctionName);
  ShowMessage(FunctionName);
end;
[/code]
 [2006-12-24 14:01 UTC] rrichards@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

dupe of bug #34564
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 18:05:54 2023 UTC