php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39102 Can't load extensions!!
Submitted: 2006-10-10 01:13 UTC Modified: 2006-10-10 14:32 UTC
From: nicodoggie at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 5.1.6 OS: Win XP
Private report: No CVE-ID: None
 [2006-10-10 01:13 UTC] nicodoggie at gmail dot com
Description:
------------
I'm running Apache 1.33.34 on Win XP

I've tried everything to load the extensions...
I've changed my extension_dir to the following:

1) c:\php\ext
2) c:/php/ext
3) ./ext
4) .\ext

and I've uncommented the particular extensions I need
(xsl, mysql)

I've already added C:\php to the PATH Env Variable in my system, so the dlls that are bundled aren't a problem...

but then they still don't load.

When i tried php -m on the console it did turn up, so I considered using PHP as CGI, to no avail, as I tried
<?php phpinfo(); ?> it still didn't find the new extensions...


Reproduce code:
---------------
<?php phpinfo(); 

if(!extension_loaded('xsl')){
 echo "<p>XSL IS LOADED</p>";
}

?>

Expected result:
----------------
The new extensions to be displayed in one of the tables...
and

XSL IS LOADED

Actual result:
--------------
none of the new extensions turned up, nor did the echoed that was to be displayed as output

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-10 05:42 UTC] albertbrian at gmail dot com
This is actually not a bug. It's just a problem for newbie.

1) Set extension_dir to correct folder you have extension files. It has to end with /. Your setting: c:\php\ext or c:/php/ext or ./ext or .\ext = incorrect

2) Some of extensions require its special files. You should read document for details.

3) Logs :)
 [2006-10-10 06:33 UTC] albertbrian at gmail dot com
Besides, you seem to forget that you have to remove ";" before extension (xsl, mysql) what you needed. Take a look in php.ini

...
;extension=php_msql.dll
...

Again, this is not a bug. It's just a problem of user.
 [2006-10-10 08:54 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2006-10-10 14:18 UTC] nicodoggie at gmail dot com
I'm sorry, I guess I should've mentioned that I did uncomment the particular extension I wanted... I kinda thought that was pretty obvious...

I tried example no. 3 then no. 1 because these were frequent in the documentations, the trailing slash wasn't in any of those but i tried it anyway, but then I forgot to add that in my bug report...

The special files, the dlls, are all in the C:\php so I added that folder in the PATH environment variable on windows... 

I guess this might be my own fault, being a newbie and all, sorry if I'm too persistent, but then there are a lot of people having this problem, and if someone did address this problem, in documentation or if someone really looked into this... I didn't seem to have this trouble in 5.0.1, the version I installed when I learned PHP...
 [2006-10-10 14:32 UTC] tony2001@php.net
No bug here, documentation describes in details what should be done in order to make mysql extension work on Windows.
Please follow the instructions in the docs: http://php.net/mysql
 [2019-02-07 12:24 UTC] celestinoxp at hotmail dot com
PHP Master (Snap), can't load extensions in Windows 10.
 [2019-02-07 12:27 UTC] spam2 at rhsoft dot net
> PHP Master (Snap), can't load extensions in Windows 10

seriously? as comment with no information to *12 years* old bugreport?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 11:05:53 2022 UTC