php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #39087 filetype() or is_dir() not recognizing a directory
Submitted: 2006-10-09 05:41 UTC Modified: 2006-10-09 22:49 UTC
From: scottayy at gmail dot com Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.1.6 OS: Windows XP Pro SP2 Build 2600
Private report: No CVE-ID: None
 [2006-10-09 05:41 UTC] scottayy at gmail dot com
Description:
------------
PHP fails to recognize directories when looping through a directory.  filetype() says lstat() fails, and is_dir() returns false.

I have the following directory structure.

/
/themes/
/themes/crap/
/themes/default/

Using this simple script to loop through the themes directory and get directory names:

Reproduce code:
---------------
<?php
//gather available themes
function get_available_themes()
{
	if($handle = @opendir('themes'))
	{
		$themes = array();
		while(false !== ($file = readdir($handle)))
		{
			if(is_dir($file) && ($file != '.' && $file != '..'))
			{
				$themes[] = $file;
			}
		}
		
		if(empty($themes))
		{
			return false;
		}
	} else
	{
		return false;
	}
	
	return $themes;
}


if($themes = get_available_themes())
{
	echo '<pre>';
	print_r(get_available_themes());
	echo '</pre>';
} else
{
	echo 'No themes could be found.';
}
?>

Expected result:
----------------
Array
(
   [0] => crap,
   [1] => default
)

Actual result:
--------------
The function returns false because the array actually contains:

Array
(
)

If I echo out $file during the while() loop, I see

.
..
crap
default

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-10-09 05:47 UTC] scottayy at gmail dot com
Sorry, I forgot to mention that when looping through, '.' and '..' are recognized as directories with filetype() and is_dir(), but the directories I created are not.
 [2006-10-09 09:20 UTC] judas dot iscariote at gmail dot com
Please, go and get a couple of cofee :) this is of course not a bug, but the expected behaviuor.

your code is checking if the $file dir, exists in the **current directory** and **not** in the "themes" directory ;P
you need to prepend the **base directory** name in the loop.

I suggest you try something like http://www.php.net/~helly/php/ext/spl/directoryfilterdots_8inc-source.html for your work.
 [2006-10-09 09:46 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip


 [2006-10-09 09:47 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2006-10-09 22:49 UTC] scottayy at gmail dot com
Sorry.  I have worked with these functions many -- many -- times.  I guess they just have always been in the directory I was already working in.  So, the failure seemed a bit odd to me in this situation.  Sorry for wasting your time and thank you for the quick responses!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 18:01:23 2020 UTC