php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38991 Can not post HTML-Tags
Submitted: 2006-09-29 10:31 UTC Modified: 2010-12-20 12:19 UTC
From: info at optima-software dot de Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.1.6 OS: Linux version 2.6.17-gentoo-r4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at optima-software dot de
New email:
PHP Version: OS:

 

 [2006-09-29 10:31 UTC] info at optima-software dot de
Description:
------------
Since the last php-update I can not POST html-tags inside a string. If I create a simple form within a textarea, after submit var_dump($_POST) outputs just plain-text without the html-tags. As a result of that, all CMS on my server don't work anymore. 

See what I did inside the code-area.

PHP Version 5.1.6-pl4-gentoo

configure command
++++++++++++++++++++++++++++++++++++++++++++
'./configure' '--prefix=/usr/lib/php5' '--host=i686-pc-linux-gnu' '--mandir=/usr/lib/php5/man' '--infodir=/usr/lib/php5/info' '--sysconfdir=/etc' '--cache-file=./config.cache' '--disable-cli' '--with-apxs2=/usr/sbin/apxs2' '--with-config-file-path=/etc/php/apache2-php5' '--with-config-file-scan-dir=/etc/php/apache2-php5/ext-active' '--without-pear' '--enable-bcmath' '--with-bz2' '--enable-calendar' '--disable-ctype' '--with-curl' '--without-curlwrappers' '--disable-dbase' '--disable-exif' '--without-fbsql' '--without-fdftk' '--disable-filepro' '--enable-ftp' '--with-gettext' '--with-gmp' '--disable-hash' '--without-hwapi' '--without-informix' '--without-kerberos' '--enable-mbstring' '--with-mcrypt' '--disable-memory-limit' '--without-mhash' '--without-ming' '--without-msql' '--without-mssql' '--with-ncurses' '--with-openssl' '--with-openssl-dir=/usr' '--disable-pcntl' '--with-pgsql' '--disable-posix' '--without-pspell' '--without-recode' '--disable-simplexml' '--disable-shmop' '--without-snmp' '--enable-soap' '--enable-sockets' '--without-sybase' '--without-sybase-ct' '--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm' '--with-tidy' '--disable-tokenizer' '--disable-wddx' '--with-xmlrpc' '--without-xsl' '--with-zlib' '--disable-debug' '--enable-dba' '--without-cdb' '--with-db4' '--without-flatfile' '--with-gdbm' '--with-inifile' '--without-qdbm' '--with-freetype-dir=/usr' '--with-t1lib=/usr' '--disable-gd-jis-conv' '--enable-gd-native-ttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gd' '--with-mysql=/usr/lib/mysql' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-mysqli=/usr/bin/mysql_config' '--without-pdo-dblib' '--with-pdo-mysql=/usr' '--without-pdo-odbc' '--with-pdo-pgsql' '--with-pdo-sqlite=/usr' '--with-readline' '--without-libedit' '--without-mm' '--with-sqlite=/usr' '--enable-sqlite-utf8'
++++++++++++++++++++++++++++++++++++++++++++

Reproduce code:
---------------
<form action="#" method="post">
  <fieldset style="width: 300px; margin: auto;">
    <legend>A simple form</legend>
    <label for="id_textarea">Input some text with html-tags here</label><br />     
    <textarea id="id_textarea" name="text" rows="10" cols="50"></textarea><br />
    <input type="submit" name="name" value="Submit"/>
  </fieldset>
</form>
<br />
<?php
  if ( isset ($_POST['text']) ){
  	$output  = '<div>' . "\r\n";
    $output .= "\t" . '<h2>The output of $_POST inside a pre-tag</h2>' . "\r\n";
    $output .= "\t" . '<pre style="border: 1px solid #ccc; padding: 5px;">';
    $output .= $_POST['text'];
    $output .= '</pre>' . "\r\n";
    $output .= '</div>' . "\r\n";
    echo($output);
  }
?>

Expected result:
----------------
Output of the string I sent.

Actual result:
--------------
Output of plain-text without html-tags

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-29 10:42 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2006-09-29 15:21 UTC] info at optima-software dot de
I found it, and imho this is a real BUG. But not a PHP rather than a pecl bug.

It is already documented:
http://pecl.php.net/bugs/bug.php?id=7571

WORKAROUND:
Inside the /ext dir you can find a filter.ini
Uncomment the one and only line:
;extension=filter.so
 [2010-12-20 12:19 UTC] jani@php.net
-Package: Tidy +Package: Filter related
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 08:03:34 2021 UTC