php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38921 pdo lost the first row data:with firebird blob data
Submitted: 2006-09-22 09:24 UTC Modified: 2007-01-27 12:54 UTC
From: achun dot shx at gmail dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.1.6 OS: windows
Private report: No CVE-ID: None
 [2006-09-22 09:24 UTC] achun dot shx at gmail dot com
Description:
------------
on firebird/interbase table.
pdo fetch data .
lost the first row data when the field type is blob.
php 5.11/5.12 too

Reproduce code:
---------------
//sql code
CREATE TABLE test (
    ID   INTEGER,
    DAT  BLOB SUB_TYPE 1 SEGMENT SIZE 80
);
//inset any data
INSERT INTO test (ID,DAT) VALUES (1,'aaa');
INSERT INTO test (ID,DAT) VALUES (2,'bbb');
//php code
$dbh = new PDO("firebird:dbname=xxx",'SYSDBA','masterkey');
$sth=$dbh->query('SELECT * from test;');
while ($row=$sth->fetch(2)){
       print_r($row);
}
//lost the first row data VALUES (1,'aaa')
Array
(
    [ID] => 
    [DAT] => 
)
Array
(
    [ID] => 2
    [DAT] => bbb
)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-01-27 00:50 UTC] drew dot winther at netce dot com
This is a dupe of http://bugs.php.net/bug.php?id=35386
 [2007-01-27 12:54 UTC] tony2001@php.net
Confirmed, see bug #35386.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 18:01:22 2020 UTC