php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38911 "Printer Friendly" Documentation Has Vanished
Submitted: 2006-09-21 13:46 UTC Modified: 2007-01-13 18:18 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jaes at gogo dot co dot nz Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: NA
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2006-09-21 13:46 UTC] jaes at gogo dot co dot nz
Description:
------------
The online documentation until sometime last week included "Printer Friendly" versions.  These versions were extremely useful for loading into embedded viewers in editors as a context-help for php functions while programming.

In particular, the InfoViewer Plugin for jEdit, through the infoviewer-help macro used the printer friendly versions to display context help for PHP functions in jEdit.  Unfortunatly context help for PHP functions in jEdit, with user notes is now unusable because of the deficiencies in Java's HTML display widget, making the non-printer-friendly page unreadable.

As I say, these versions appear to have vanished, I've searched around but I can't even see any discussion that has occurred regarding the removal of these versions, as far as I can see somebody "took the initiative" and deleted them.

I would like to request that these versions are restored to thier rightful place.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-21 14:01 UTC] philip@php.net
Reclassified
 [2006-09-21 18:52 UTC] goba@php.net
The idea behind removing printer-friendly versions is that these days every page should be printer-friendly. And php.net manuals pages are nicely printing nowadays. 

The jEdit InfoViewer Plugin is capable of using an external browser to display pages, and people use it successfuly this way.
 [2006-09-23 00:06 UTC] jaes at gogo dot co dot nz
"The jEdit InfoViewer Plugin is capable of using an external browser to display pages, and people use it successfuly this way."

But this cannot be docked, the internal, dockable window cannot display the non-printable version correctly, and having a context help window docked under/beside the editor buffer is much nicer than having a full browser popup just to check the argument order of something.
 [2007-01-13 18:18 UTC] bjori@php.net
You can still fetch the plain html docs from 
php.net/download-docs
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 06:01:23 2020 UTC