php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38852 XML-RPC Breaks iconv
Submitted: 2006-09-16 01:04 UTC Modified: 2006-12-20 10:38 UTC
From: davey@php.net Assigned: bjori
Status: Closed Package: XMLRPC-EPI related
PHP Version: 5.2.0RC4 OS: OS X 10.4.7
Private report: No CVE-ID:
 [2006-09-16 01:04 UTC] davey@php.net
Description:
------------
When compiling with ext/xmlrpc, the 'iconv()' extension is 
missing.

This causes some of the following tests to fail:

http://hashphp.org/pastebin.php?format=plain&pid=8487

- Davey


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-16 01:07 UTC] bjori@php.net
The extension isn't really missing, only the iconv() 
function is named libiconv().

ext/xmlrpc/config.m4 needs some tweaking like 
ext/iconv/config.m4 I guess...
 [2006-09-17 08:01 UTC] tony2001@php.net
Can't reproduce.
What kind of iconv is that? Which version? Where are the headers and the libs?
 [2006-09-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-12-20 10:38 UTC] bjori@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 19:01:51 2014 UTC