php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38778 Mbstring compile error
Submitted: 2006-09-11 08:43 UTC Modified: 2006-09-11 11:27 UTC
From: jari at personal dot fi Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 5.1.6 OS: Fedora Core 5
Private report: No CVE-ID: None
 [2006-09-11 08:43 UTC] jari at personal dot fi
Description:
------------
Hi to everyone,

I have annoying error when compiling PHP (Fedora 5 [i386]).

I try compile with this:

./configure --with-zlib-dir=/usr/local/ --enable-shared --enable-static --enable-memory-limit --enable-magic-quotes --disable-short-tags --with-apxs2=/usr/local/apache2/bin/apxs --with-bz2 --without-sqlite --with-mysql=/usr/local/mysql --enable-exif --with-mm --enable-calendar --with-gd=/usr/local/ --with-freetype-dir=/usr/local/include/freetype2/ --with-png-dir=/usr/local/include/ --with-jpeg --enable-gd-native-ttf --enable-mbstring

...and got result like this:

In file included from /usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:37:
/usr/lib/gcc/i386-redhat-linux/4.0.2/include/varargs.h:4:2: error: #error "GCC no longer implements <varargs.h>."
/usr/lib/gcc/i386-redhat-linux/4.0.2/include/varargs.h:5:2: error: #error "Revise your code to use <stdarg.h>."
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c: In function 'onig_error_code_to_str':
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:194: error: syntax error before 'va_dcl'
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:200: error: syntax error before 'va_list'
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:269: error: syntax error before 'va_dcl'
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:273: error: redefinition of parameter 's'
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:192: error: previous definition of 's' was here
/usr/src/php-5.1.6/ext/mbstring/oniguruma/regerror.c:275: error: syntax error before 'va_list'
make: *** [ext/mbstring/oniguruma/regerror.lo] Error 1


I have compiled PHP with result ok WITHOUT --enable-calendar option previously. I have installed only Zend Optimizer 3.0.1 afted PHP and next when I try to recompile with calendar, it fails...

Seems that other fellows have this kind of problems too so what's wrong?


--WIZ--

Reproduce code:
---------------
See previous

Expected result:
----------------
Compile OK

Actual result:
--------------
Make failure...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-11 11:27 UTC] tony2001@php.net
Duplicate of #38452.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 01:03:38 2021 UTC