php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38704 OCI-Lob::load returns empty string
Submitted: 2006-09-04 01:54 UTC Modified: 2016-03-08 01:05 UTC
From: terry dot cullen at uq dot edu dot au Assigned: sixd (profile)
Status: Closed Package: OCI8 related
PHP Version: 5.1.6 OS: Solaris 10x86
Private report: No CVE-ID: None
 [2006-09-04 01:54 UTC] terry dot cullen at uq dot edu dot au
Description:
------------
When fetching an OCI-Lob from an oracle database, the OCI-Lob::load method returns an empty string on solaris x8610.

The istanceof function fails as well because the the '-' in OCI-Lob.

Configure flags:
'./configure' '--prefix=/opt/local/php5' '--with-apxs2=/opt/local/apache/bin/apxs' '--enable-safe-mode' '--with-exec-dir=/opt/local/php5/bin' '--enable-bcmath' '--enable-gd-native-ttf' '--enable-soap' '--enable-sockets' '--disable-rpath' '--enable-ftp' '--with-gd' '--with-gettext' '--with-imap=/src/Web/IMap/imap-2004g' '--with-imap-ssl=/src/Web/IMap/imap-2004g' '--with-jpeg-dir=/usr/lib/amd64/' '--with-ldap=/usr' '--with-mcrypt=/opt/local' '--with-png-dir=/usr/lib/amd64/' '--with-pspell=/usr' '--with-openssl=/opt/csw' '--with-zlib' '--with-libxml-dir=/opt/csw' '--with-mysql=/opt/local/mysql/mysql' '--with-oci8=/opt/local/oracle/10103_client' '--with-xpm-dir=/usr/lib' '--enable-memory-limit' '--with-gdbm=/opt/csw' '--with-db4=/opt/csw/bdb4' '--with-mhash=/opt/local/mhash' '--with-curl=/opt/local/curl' '--with-pear=/opt/local/php5' '--enable-pdo=shared' '--with-pdo-sqlite=shared' '--with-sqlite=shared' '--with-mbstring' '--with-mysqli=/opt/local/mysql/mysql/bin/mysql_config' '--with-ld=/usr/sfw/i386-sun-solaris2.10/bin/ld' '--with-gnu-ld'

Reproduce code:
---------------
http://www.cwd.net.au/OCI_Lob_Load_problem.phps

Expected result:
----------------
The OCI-Lob::load method returns the string.

Old but working server output:
    Connect Id: Resource id #2Object instanceof OCI_Lob - failed

Timetable notes: OCI-Lob Object ( [descriptor] => Resource id #6 ) is_a(Object, OCI-Lob) - succeeded
    int(0) int(59) bool(true) string(59) "1.4 Unit Additional Timetable Information:" 
 

Actual result:
--------------
 
New put broken lob server output:
Connect Id: Resource id #2Object instanceof OCI_Lob - failed

    Timetable notes: OCI-Lob Object ( [descriptor] => Resource id #6 ) is_a(Object, OCI-Lob) - succeeded
    int(0) int(59) bool(true) string(0) "" 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-09-04 08:31 UTC] tony2001@php.net
Please install OCI8 1.2.2 from PECL.
 [2006-09-04 10:41 UTC] terry dot cullen at uq dot edu dot au
I recompiled PHP5.1.6 without OCI8.
Then I installed OCI8 via PECL.

This is the PHP info for OCI8 using the static oci;
oci8
OCI8 Support 	enabled
Revision 	$Revision: 1.269.2.18 $
Active Persistent Connections 	0
Active Connections 	0
Oracle Version 	10.1
Compile-time ORACLE_HOME 	/opt/local/oracle/10103_client
Libraries Used 	no value
Temporary Lob support 	enabled
Collections support 	enabled

This is the PHP info for OCI8 using the pecl install oci8;
oci8
OCI8 Support 	enabled
Version 	1.2.1
Revision 	$Revision: 1.269.2.16.2.21 $
Active Persistent Connections 	0
Active Connections 	0
Oracle Version 	10.1
Compile-time ORACLE_HOME 	/opt/local/oracle/10103_client
Libraries Used 	no value
Temporary Lob support 	enabled
Collections support 	enabled

This is the PHP info for OCI8 using the source compile of oci;
oci8
OCI8 Support 	enabled
Version 	1.2.1
Revision 	$Revision: 1.269.2.16.2.21 $
Active Persistent Connections 	0
Active Connections 	0
Oracle Version 	10.1
Compile-time ORACLE_HOME 	/opt/local/oracle/10103_client
Libraries Used 	no value
Temporary Lob support 	enabled
Collections support 	enabled

The pecl oci seems to be a less recent version.
I will have our guy with the oracle access test it in the morning.
 [2016-03-08 01:05 UTC] sixd@php.net
-Package: Oracle related +Package: OCI8 related -Assigned To: +Assigned To: sixd
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Oct 07 22:05:53 2022 UTC