php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #38668 Call to undefined function: bindtextdomain()
Submitted: 2006-08-31 10:03 UTC Modified: 2006-08-31 10:10 UTC
From: alti at ip-label dot net Assigned:
Status: Not a bug Package: Gettext related
PHP Version: 4.4.4 OS: windows XP pro
Private report: No CVE-ID:
 [2006-08-31 10:03 UTC] alti at ip-label dot net
Description:
------------
I need gettext module with apache2 and windows for php4.4.4.
So I have the php_gettext.dll (and also libintl-1.dll and iconv.dll) in the dlls directory.
In my php.ini I have extension=php_gettext.dll

but each time I have Call to undefined function: Bindtextdomain()


Reproduce code:
---------------
<?php
@setlocale("LC_ALL", "en_en");
putenv('LANGUAGE=en_en');

bindtextdomain ("Mydomain","./translation");

textdomain ('Mydomain');

echo gettext("ceci est un test");
?>

Expected result:
----------------
Display some text : "this is a test"

Actual result:
--------------
Fatal error: Call to undefined function: bindtextdomain() in......

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-08-31 10:10 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 05:03:19 2014 UTC